Support Desk Emails Undeliverable
Incident Report for OttoLearn
Resolved
This incident has been resolved.
Posted Feb 20, 2023 - 12:21 CST
Investigating
We are currently investigating an issue where inbound emails to support@smarteru.com are not being delivered. We hope to have an update soon, and resolve this as soon as possible.
Posted Feb 20, 2023 - 12:00 CST