Analytics Data Missing
Incident Report for OttoLearn
Resolved
The analytics data has been fully restored and verified. This issue is now resolved.
Posted Dec 15, 2023 - 08:59 CST
Update
There have been no new reports or discovering of issues or discrepancies. We will be continuing to monitor the analytics data, and provide another update on Friday, December 15th, 2023.
Posted Dec 14, 2023 - 16:41 CST
Update
We are continuing to monitor the analytics data for any issues or discrepancies.

We will provide another update on Thursday, December 14th, 2023.
Posted Dec 13, 2023 - 16:06 CST
Monitoring
The analytics data has been restored, and our team is monitoring the update to ensure there are no remaining issues.
Posted Dec 12, 2023 - 08:55 CST
Update
We have successfully applied a fix for the missing analytics data today. The missing data will be restored for Tuesday, December 12th, 2023.

We will provide an update once we have confirmed the data has been restored.
Posted Dec 11, 2023 - 15:04 CST
Update
We have isolated the root cause of this issue which prevents new records from being written to analytics database tables.

A solution has been established by reconfiguring the database tables. We plan to have the solution ready for Monday, December 11th, 2023, and the rebuilding of missing data will then be completed by Tuesday, December 12th, 2023.

An update will be provided on Monday regarding deployment of the fix to the analytics databases.
Posted Dec 08, 2023 - 16:17 CST
Update
We are still working towards a solution to this issue, and have more detailed information regarding the impact of this:

- Activity History, Learner Engagement, Assignment in Mastery, and Knowledge Gap and Lift show '0'
- Automated daily data exports that feed into external data visualization tool are impacted, which includes PowerBI
- Weekly Summary emails will have inaccurate data
Posted Dec 06, 2023 - 17:21 CST
Identified
We have identified an issue where the analytics data is not populating and will display as '0'. This impacts the Analytics page, emails, and PowerBI reporting.

The Organization Data export feature is not impacted by this issue.

We will provide updates as we progress towards a solution to this issue.
Posted Dec 05, 2023 - 15:43 CST
This incident affected: Admin App and API.